Legacy cards worden officieel niet meer ondersteund door EDIUS Pro 8/9. Toch werken ze zonder probleem met EDIUS 8 (echter niet met EDIUS 9) als de nieuwste drivers (zie hieronder) van EDIUS 7 worden geinstalleerd (zonder officiƫle ondersteuning):


Let op: HD Spark en HD Spark Pro worden nog steeds ondersteund door EDIUS 8 en EDIUS 9.